We recommend an updated version of Google Chrome or Firefox, but you can use any modern browser, including Internet Explorer (version 12 or greater).

Logikcull is an HTML5 based application pushing the limits of what can be done in the browser. Older browsers simply don’t offer the performance requirements Logikcull demands, and we don’t want your experience to suffer because of an old browser.

Did this answer your question?